add a flag "IGNORE_ERRORS", which can be used to ignore build errors in packages
[openwrt/svn-archive/archive.git] / include / host.mk
index cc0436e7b04b42fcd293243b96c02ce5b035810a..00eb1f55aafef0a1072e0dfa07b4071eaee5aa86 100644 (file)
@@ -1,16 +1,18 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
+TMP_DIR ?= $(TOPDIR)/tmp
 -include $(TMP_DIR)/.host.mk
 
 export TAR
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
+.PRECIOUS: $(TMP_DIR)/.host.mk
 $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
        @mkdir -p $(TMP_DIR)
        @( \
@@ -28,6 +30,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                TAR=`which gtar 2>/dev/null`; \
                [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
                echo "TAR:=$$TAR" >> $@; \
+               FIND=`which gfind 2>/dev/null`; \
+               [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
+               echo "FIND:=$$FIND" >> $@; \
                echo "BASH:=$(shell which bash)" >> $@; \
                if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
                        echo 'FIND_L=find -L $$(1)' >>$@; \