fixes for a few build errors on osx without fink
[openwrt/svn-archive/archive.git] / include / host.mk
index 6c0dcd6699f39d2202d396b6b45fb77838cf4ea9..8b4ce3d24b9101ebe1ab1603da33a75decd56273 100644 (file)
@@ -5,11 +5,14 @@
 # See /LICENSE for more information.
 #
 
-include $(TOPDIR)/.host.mk
+include $(TMP_DIR)/.host.mk
 
 export TAR
 
-$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
+ifneq ($(__host_inc),1)
+__host_inc:=1
+$(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
+       @mkdir -p $(TMP_DIR)
        @( \
                HOST_OS=`uname`; \
                case "$$HOST_OS" in \
@@ -22,14 +25,19 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
                echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
-               TAR=`which gtar`; \
-               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar`; \
+               TAR=`which gtar 2>/dev/null`; \
+               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
                echo "TAR:=$$TAR" >> $@; \
-               if $$TAR --version 2>&1 | grep 'GNU' >/dev/null; then \
-                       echo "TAR_WILDCARDS:=--wildcards" >> $@; \
-               fi; \
-               ZCAT=`which gzcat`; \
-               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat`; \
+               ZCAT=`which gzcat 2>/dev/null`; \
+               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat 2>/dev/null`; \
                echo "ZCAT:=$$ZCAT" >> $@; \
+               echo "BASH:=$(shell which bash)" >> $@; \
        )
 
+endif
+
+ifeq ($(HOST_OS),Linux)
+  XARGS:=xargs -r
+else
+  XARGS:=xargs
+endif