[kernel] update to 2.6.27.35
[openwrt/svn-archive/archive.git] / include / host.mk
index 8b2e56ce510bf7c5d9325c755d82a5b6196c9bfc..b93ab8d536d2f0df3e973ea271b1c090dca04264 100644 (file)
@@ -1,17 +1,20 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
--include $(TMP_DIR)/.host.mk
-
-export TAR
 TMP_DIR ?= $(TOPDIR)/tmp
+ifeq ($(if $(TARGET_BUILD),,$(DUMP)),)
+  -include $(TMP_DIR)/.host.mk
+endif
+
+export TAR FIND
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
+.PRECIOUS: $(TMP_DIR)/.host.mk
 $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
        @mkdir -p $(TMP_DIR)
        @( \
@@ -27,20 +30,23 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
                echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
                TAR=`which gtar 2>/dev/null`; \
+               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which gnutar 2>/dev/null`; \
                [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
                echo "TAR:=$$TAR" >> $@; \
+               FIND=`which gfind 2>/dev/null`; \
+               [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
+               echo "FIND:=$$FIND" >> $@; \
                echo "BASH:=$(shell which bash)" >> $@; \
-               if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
-                       echo 'FIND_L=find -L $$(1)' >>$@; \
+               if $$FIND -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
+                       echo "FIND_L=$$FIND -L \$$(1)" >>$@; \
                else \
-                       echo 'FIND_L=find $$(1) -follow' >> $@; \
+                       echo "FIND_L=$$FIND \$$(1) -follow" >> $@; \
+               fi; \
+               if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
+                       echo 'XARGS:=xargs -r' >> $@; \
+               else \
+                       echo 'XARGS:=xargs' >> $@; \
                fi; \
        )
 
 endif
-
-ifeq ($(HOST_OS),Linux)
-  XARGS:=xargs -r
-else
-  XARGS:=xargs
-endif