Also load compat_ioctl32 for V4L devices to load
[openwrt/svn-archive/archive.git] / include / image.mk
index 9c170af11bc64f34b8f2427e3c18cd90d50d8370..08f240fe238135e9ae18cb4d895f5f65459c6421 100644 (file)
@@ -7,6 +7,7 @@
 
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/host.mk
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
 ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -37,14 +38,17 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
+               $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x40000 -o $(KDIR)/root.jffs2-256k -d $(BUILD_DIR)/root
 
                
                # add End-of-Filesystem markers
                $(call add_jffs2_mark,$(KDIR)/root.jffs2-64k)
                $(call add_jffs2_mark,$(KDIR)/root.jffs2-128k)
+               $(call add_jffs2_mark,$(KDIR)/root.jffs2-256k)
        
                $(call Image/Build,jffs2-64k)
                $(call Image/Build,jffs2-128k)
+               $(call Image/Build,jffs2-256k)
     endef
   endif
     
@@ -61,8 +65,11 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
-  
-  
+else
+  define Image/BuildKernel
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+       $(call Image/Build/Initramfs)
+  endef
 endif
 
 
@@ -77,9 +84,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
-       find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(BUILD_DIR)/root -type d | xargs chmod 0755
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
+       find $(BUILD_DIR)/root -type f -perm +0100 | $(XARGS) chmod 0755
+       find $(BUILD_DIR)/root -type d | $(XARGS) chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef