mpc83xx: add 2.6.33 support
[openwrt/svn-archive/archive.git] / include / image.mk
index 7f2307919be33df95950915ac05d6c1823421b9f..0ce6336cc597f75a8dcf80ae3cb3a1dd2c3b5edc 100644 (file)
@@ -23,7 +23,7 @@ JFFS2OPTS     :=  --pad --big-endian --squash
 SQUASHFS_OPTS :=  -be
 endif
 
-ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25),)
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
 USE_SQUASHFS3 := y
 endif
 
@@ -62,14 +62,13 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                $(call Image/Build,jffs2-$(1))
     endef
     define Image/mkfs/jffs2
-               rm -rf $(TARGET_DIR)/jffs
                $(foreach SZ,$(JFFS2_BLOCKSIZE),$(call Image/mkfs/jffs2/sub,$(SZ)))
     endef
   endif
 
   ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),y)
     define Image/mkfs/squashfs
-               @mkdir -p $(TARGET_DIR)/jffs
+               @mkdir -p $(TARGET_DIR)/overlay
                $(MKSQUASHFS_CMD) $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
                $(call Image/Build,squashfs)
     endef
@@ -86,6 +85,15 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/openwrt-$(BOARD)-rootfs.cpio.gz )
     endef
   endif
+  ifeq ($(CONFIG_TARGET_ROOTFS_UBIFS),y)
+    define Image/mkfs/ubifs
+               $(CP) ./ubinize.cfg $(KDIR)
+               $(STAGING_DIR_HOST)/bin/mkfs.ubifs $(UBIFS_OPTS) -o $(KDIR)/root.ubifs -d $(TARGET_DIR)
+               (cd $(KDIR); \
+               $(STAGING_DIR_HOST)/bin/ubinize $(UBINIZE_OPTS) -o $(KDIR)/root.ubi ubinize.cfg)
+               $(call Image/Build,ubi)
+    endef
+  endif
 else
   define Image/BuildKernel
        cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
@@ -95,7 +103,7 @@ endif
 
 define Image/Checksum
        ( cd ${BIN_DIR} ; \
-               $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | xargs \
+               $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | sort | xargs \
                md5sum --binary > md5sums \
        )
 endef
@@ -118,9 +126,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       - find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
-       - find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
-       - find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
+       - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -print0 | $(XARGS) -0 chmod 0644
+       - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod 0755
+       - $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod 0755
        $(INSTALL_DIR) $(TARGET_DIR)/tmp
        chmod 0777 $(TARGET_DIR)/tmp
 endef
@@ -150,6 +158,7 @@ ifneq ($(IB),1)
        $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
        $(call Image/mkfs/iso)
+       $(call Image/mkfs/ubifs)
        $(call Image/Checksum)
 else
   install: compile install-targets
@@ -160,6 +169,7 @@ else
        $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
        $(call Image/mkfs/iso)
+       $(call Image/mkfs/ubifs)
        $(call Image/Checksum)
 endif