ignore errors in the find command for dep checks
[openwrt/svn-archive/archive.git] / include / image.mk
index 9c170af11bc64f34b8f2427e3c18cd90d50d8370..0e6a7cdbeab280b9615b210d0c4313f042e802ed 100644 (file)
@@ -61,8 +61,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
-  
-  
+else
+  define Image/BuildKernel
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+  endef
 endif
 
 
@@ -77,9 +79,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
-       find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(BUILD_DIR)/root -type d | xargs chmod 0755
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs -r chmod 0644
+       find $(BUILD_DIR)/root -type f -perm +0100 | xargs -r chmod 0755
+       find $(BUILD_DIR)/root -type d | xargs -r chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef