fix typo
[openwrt/svn-archive/archive.git] / include / image.mk
index 06516791805b082711a321d483977c675d976ad7..59204581d011d87ea766dc4d823b0aa841376a5c 100644 (file)
@@ -48,16 +48,19 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   
 endif
 
+
 ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
+  E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
+  
   define Image/mkfs/ext2
-               $(STAGING_DIR)/bin/genext2fs -q -b 8192 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR)/bin/genext2fs -q -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
        find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
        find $(BUILD_DIR)/root -type d | xargs chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp