brcm-2.4: Fixed preinit and failsafe switch configuration
[openwrt/svn-archive/archive.git] / include / image.mk
index af4e102567bddea7af6fc2044c5c5efa635a4f50..6df656b9f4a2aaedc576600b695ea4254b84833b 100644 (file)
@@ -129,7 +129,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_TARGZ),)
 endif
 
 ifneq ($(CONFIG_TARGET_ROOTFS_EXT2FS),)
-  E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
+  E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024)))
 
   define Image/mkfs/ext2
                $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2