only squash owners, not permissions, when generating ext2 images
[openwrt/svn-archive/archive.git] / include / image.mk
index 13b722981a7df29807b11a39ac78793c4888034d..702434ec86152099dc622ff14d767f4f63d731c8 100644 (file)
@@ -4,6 +4,9 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
+include $(INCLUDE_DIR)/prereq.mk
+include $(INCLUDE_DIR)/kernel.mk
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
 ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -50,10 +53,10 @@ endif
 
 
 ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
-  E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_SIZE)*1024)))
+  E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
   
   define Image/mkfs/ext2
-               $(STAGING_DIR)/bin/genext2fs -q -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif
@@ -72,10 +75,12 @@ define Image/mkfs/prepare
 endef
 
 define BuildImage
-compile:
+download:
+prepare:
+compile: compile-targets
        $(call Build/Compile)
 
-install:
+install: compile install-targets
        $(call Image/Prepare)
        $(call Image/mkfs/prepare)
        $(call Image/BuildKernel)
@@ -84,16 +89,12 @@ install:
        $(call Image/mkfs/tgz)
        $(call Image/mkfs/ext2)
        
-clean:
+clean: clean-targets
        $(call Build/Clean)
-endef
 
 compile-targets:
 install-targets:
 clean-targets:
+endef
+
 
-download:
-prepare:
-compile: compile-targets
-install: compile install-targets
-clean: clean-targets