fix jffs2 images
[openwrt/svn-archive/archive.git] / include / image.mk
index 6805389d72529197c8bf5d98889fedb8a7abd46c..a421edd97f2e30558637c5cd361d502e0393ef1e 100644 (file)
@@ -5,7 +5,9 @@
 # See /LICENSE for more information.
 #
 
+include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/host.mk
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
 ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -16,20 +18,32 @@ JFFS2OPTS     :=  --pad --big-endian --squash
 SQUASHFS_OPTS :=  -be
 endif
 
+JFFS2_BLOCKSIZE ?= 64k 128k
+
+define add_jffs2_mark
+       echo -ne '\xde\xad\xc0\xde' >> $(1)
+endef
+
+# pad to 64k and add jffs2 end-of-filesystem mark
+# do this twice to make sure that this works with 128k blocksize as well
+define prepare_generic_squashfs
+       dd if=$(1) of=$(KDIR)/tmpfile.1 bs=64k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.1)
+       dd of=$(1) if=$(KDIR)/tmpfile.1 bs=64k conv=sync
+       $(call add_jffs2_mark,$(1))
+endef
+
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   ifeq ($(CONFIG_TARGET_ROOTFS_JFFS2),y)
+    define Image/mkfs/jffs2/sub
+               @# FIXME: removing this line will cause the foreach loop below to execute the next statement only on the first iteration, don't ask why ;)
+               $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(1) -d $(BUILD_DIR)/root
+               $(call add_jffs2_mark,$(KDIR)/root.jffs2-$(1))
+               $(call Image/Build,jffs2-$(1))
+    endef
     define Image/mkfs/jffs2
                rm -rf $(BUILD_DIR)/root/jffs
-               
-               $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
-               $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
-
-               # add End-of-Filesystem markers
-               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
-               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
-       
-               $(call Image/Build,jffs2-64k)
-               $(call Image/Build,jffs2-128k)
+               $(foreach SZ,$(JFFS2_BLOCKSIZE),$(call Image/mkfs/jffs2/sub,$(SZ)))
     endef
   endif
     
@@ -43,11 +57,14 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
     
   ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
     define Image/mkfs/tgz
-               tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
+               $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
-  
-  
+else
+  define Image/BuildKernel
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+       $(call Image/Build/Initramfs)
+  endef
 endif
 
 
@@ -55,16 +72,16 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
   
   define Image/mkfs/ext2
-               $(STAGING_DIR)/bin/genext2fs -q -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
-       find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(BUILD_DIR)/root -type d | xargs chmod 0755
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
+       find $(BUILD_DIR)/root -type f -perm +0100 | $(XARGS) chmod 0755
+       find $(BUILD_DIR)/root -type d | $(XARGS) chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef
@@ -74,10 +91,17 @@ define Image/mkfs/prepare
 endef
 
 define BuildImage
-compile:
+download:
+prepare:
+ifneq ($(IB),1)
+  compile: compile-targets
        $(call Build/Compile)
+else
+  compile:
+endif
 
-install:
+ifneq ($(IB),1)
+  install: compile install-targets
        $(call Image/Prepare)
        $(call Image/mkfs/prepare)
        $(call Image/BuildKernel)
@@ -85,17 +109,25 @@ install:
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
        $(call Image/mkfs/ext2)
+else
+  install: compile install-targets
+       $(call Image/BuildKernel)
+       $(call Image/mkfs/jffs2)
+       $(call Image/mkfs/squashfs)
+       $(call Image/mkfs/tgz)
+       $(call Image/mkfs/ext2)
+endif
        
-clean:
+ifneq ($(IB),1)
+  clean: clean-targets
        $(call Build/Clean)
-endef
+else
+  clean:
+endif
 
 compile-targets:
 install-targets:
 clean-targets:
+endef
+
 
-download:
-prepare:
-compile: compile-targets
-install: compile install-targets
-clean: clean-targets