with no users left, remove support for 2.6.21
[openwrt/svn-archive/archive.git] / include / image.mk
index 70677b9c2f2f4e48ff0602e6bdf425b7c46cf937..e133f7212c3473372b3106ee4eac2785c97b6621 100644 (file)
@@ -1,13 +1,19 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
+override TARGET_BUILD=
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/kernel.mk
-KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+include $(INCLUDE_DIR)/host.mk
+
+.NOTPARALLEL:
+override MAKEFLAGS=
+override MAKE:=$(SUBMAKE)
+KDIR=$(KERNEL_BUILD_DIR)
 
 ifneq ($(CONFIG_BIG_ENDIAN),y)
 JFFS2OPTS     :=  --pad --little-endian --squash
@@ -17,57 +23,114 @@ JFFS2OPTS     :=  --pad --big-endian --squash
 SQUASHFS_OPTS :=  -be
 endif
 
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
+USE_SQUASHFS3 := y
+endif
+
+ifneq ($(USE_SQUASHFS3),)
+MKSQUASHFS_CMD := $(STAGING_DIR_HOST)/bin/mksquashfs-lzma
+else
+MKSQUASHFS_CMD := $(STAGING_DIR_HOST)/bin/mksquashfs4
+SQUASHFS_OPTS  := -comp lzma -processors 1
+endif
+
+JFFS2_BLOCKSIZE ?= 64k 128k
+
+define add_jffs2_mark
+       echo -ne '\xde\xad\xc0\xde' >> $(1)
+endef
+
+# pad to 4k, 8k, 64k, 128k and add jffs2 end-of-filesystem mark
+define prepare_generic_squashfs
+       dd if=$(1) of=$(KDIR)/tmpfile.0 bs=4k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.0)
+       dd if=$(KDIR)/tmpfile.0 of=$(KDIR)/tmpfile.1 bs=4k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.1)
+       dd if=$(KDIR)/tmpfile.1 of=$(KDIR)/tmpfile.2 bs=64k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.2)
+       dd if=$(KDIR)/tmpfile.2 of=$(1) bs=64k conv=sync
+       $(call add_jffs2_mark,$(1))
+       rm -f $(KDIR)/tmpfile.*
+endef
+
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   ifeq ($(CONFIG_TARGET_ROOTFS_JFFS2),y)
+    define Image/mkfs/jffs2/sub
+               # FIXME: removing this line will cause strange behaviour in the foreach loop below
+               $(STAGING_DIR_HOST)/bin/mkfs.jffs2 $(JFFS2OPTS) -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(1) -d $(TARGET_DIR)
+               $(call add_jffs2_mark,$(KDIR)/root.jffs2-$(1))
+               $(call Image/Build,jffs2-$(1))
+    endef
     define Image/mkfs/jffs2
-               rm -rf $(BUILD_DIR)/root/jffs
-               
-               $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
-               $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
-
-               # add End-of-Filesystem markers
-               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
-               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
-       
-               $(call Image/Build,jffs2-64k)
-               $(call Image/Build,jffs2-128k)
+               rm -rf $(TARGET_DIR)/jffs
+               $(foreach SZ,$(JFFS2_BLOCKSIZE),$(call Image/mkfs/jffs2/sub,$(SZ)))
     endef
   endif
-    
+
   ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),y)
     define Image/mkfs/squashfs
-               @mkdir -p $(BUILD_DIR)/root/jffs
-               $(STAGING_DIR)/bin/mksquashfs-lzma $(BUILD_DIR)/root $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
+               @mkdir -p $(TARGET_DIR)/jffs
+               $(MKSQUASHFS_CMD) $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
                $(call Image/Build,squashfs)
     endef
   endif
-    
+
   ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
     define Image/mkfs/tgz
-               tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
+               $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+    endef
+  endif
+
+  ifeq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),y)
+    define Image/mkfs/cpiogz
+               ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/openwrt-$(BOARD)-rootfs.cpio.gz )
     endef
   endif
-  
-  
+  ifeq ($(CONFIG_TARGET_ROOTFS_UBIFS),y)
+    define Image/mkfs/ubifs
+               $(CP) ./ubinize.cfg $(KDIR)
+               $(STAGING_DIR_HOST)/bin/mkfs.ubifs $(UBIFS_OPTS) -o $(KDIR)/root.ubifs -d $(TARGET_DIR)
+               (cd $(KDIR); \
+               $(STAGING_DIR_HOST)/bin/ubinize $(UBINIZE_OPTS) -o $(BIN_DIR)/openwrt-$(BOARD)-rootfs.ubi ubinize.cfg)
+    endef
+  endif
+else
+  define Image/BuildKernel
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+       $(call Image/Build/Initramfs)
+  endef
 endif
 
+define Image/Checksum
+       ( cd ${BIN_DIR} ; \
+               $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | xargs \
+               md5sum --binary > md5sums \
+       )
+endef
+
 
 ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
-  
+
   define Image/mkfs/ext2
-               $(STAGING_DIR)/bin/genext2fs -q -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif
 
+ifeq ($(CONFIG_TARGET_ROOTFS_ISO),y)
+  define Image/mkfs/iso
+               $(call Image/Build,iso)
+  endef
+endif
+
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
-       find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(BUILD_DIR)/root -type d | xargs chmod 0755
-       mkdir -p $(BUILD_DIR)/root/tmp
-       chmod 0777 $(BUILD_DIR)/root/tmp
+       - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -print0 | $(XARGS) -0 chmod 0644
+       - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod 0755
+       - $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod 0755
+       $(INSTALL_DIR) $(TARGET_DIR)/tmp
+       chmod 0777 $(TARGET_DIR)/tmp
 endef
 
 define Image/mkfs/prepare
@@ -75,28 +138,51 @@ define Image/mkfs/prepare
 endef
 
 define BuildImage
-compile:
+download:
+prepare:
+ifneq ($(IB),1)
+  compile: compile-targets FORCE
        $(call Build/Compile)
+else
+  compile:
+endif
 
-install:
+ifneq ($(IB),1)
+  install: compile install-targets FORCE
        $(call Image/Prepare)
        $(call Image/mkfs/prepare)
        $(call Image/BuildKernel)
        $(call Image/mkfs/jffs2)
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
+       $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
-       
-clean:
+       $(call Image/mkfs/iso)
+       $(call Image/mkfs/ubifs)
+       $(call Image/Checksum)
+else
+  install: compile install-targets
+       $(call Image/BuildKernel)
+       $(call Image/mkfs/jffs2)
+       $(call Image/mkfs/squashfs)
+       $(call Image/mkfs/tgz)
+       $(call Image/mkfs/cpiogz)
+       $(call Image/mkfs/ext2)
+       $(call Image/mkfs/iso)
+       $(call Image/mkfs/ubifs)
+       $(call Image/Checksum)
+endif
+
+ifneq ($(IB),1)
+  clean: clean-targets
        $(call Build/Clean)
-endef
+else
+  clean:
+endif
 
 compile-targets:
 install-targets:
 clean-targets:
+endef
+
 
-download:
-prepare:
-compile: compile-targets
-install: compile install-targets
-clean: clean-targets