add prereq check for python
[openwrt/svn-archive/archive.git] / include / image.mk
index fea7d1ce6f37969823961abf030855995ee758a3..efbc76db36a25d6e098463fc397d64f3b11911b8 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -50,7 +50,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                $(foreach SZ,$(JFFS2_BLOCKSIZE),$(call Image/mkfs/jffs2/sub,$(SZ)))
     endef
   endif
-    
+
   ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),y)
     define Image/mkfs/squashfs
                @mkdir -p $(TARGET_DIR)/jffs
@@ -58,15 +58,21 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                $(call Image/Build,squashfs)
     endef
   endif
-    
+
   ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
     define Image/mkfs/tgz
-               $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ .
+               $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ .
+    endef
+  endif
+
+  ifeq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),y)
+    define Image/mkfs/cpiogz
+               ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/openwrt-$(BOARD)-rootfs.cpio.gz )
     endef
   endif
 else
   define Image/BuildKernel
-       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
        $(call Image/Build/Initramfs)
   endef
 endif
@@ -74,18 +80,18 @@ endif
 
 ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
-  
+
   define Image/mkfs/ext2
                $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif
 
-ifeq ($(CONFIG_TARGET_ROOTFS_ISO),y) 
-  define Image/mkfs/iso 
-               $(call Image/Build,iso) 
-  endef 
-endif 
+ifeq ($(CONFIG_TARGET_ROOTFS_ISO),y)
+  define Image/mkfs/iso
+               $(call Image/Build,iso)
+  endef
+endif
 
 
 define Image/mkfs/prepare/default
@@ -118,6 +124,7 @@ ifneq ($(IB),1)
        $(call Image/mkfs/jffs2)
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
+       $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
        $(call Image/mkfs/iso)
 else
@@ -126,10 +133,11 @@ else
        $(call Image/mkfs/jffs2)
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
+       $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
        $(call Image/mkfs/iso)
 endif
-       
+
 ifneq ($(IB),1)
   clean: clean-targets
        $(call Build/Clean)