DESCRIPTION:= is obselete, so complain if it is used and use TITLE if no description...
[openwrt/svn-archive/archive.git] / include / image.mk
index 68ce0480d16d6c96db7fb9dd03e0ea43eb6ad495..fea7d1ce6f37969823961abf030855995ee758a3 100644 (file)
@@ -81,6 +81,12 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   endef
 endif
 
+ifeq ($(CONFIG_TARGET_ROOTFS_ISO),y) 
+  define Image/mkfs/iso 
+               $(call Image/Build,iso) 
+  endef 
+endif 
+
 
 define Image/mkfs/prepare/default
        find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
@@ -113,6 +119,7 @@ ifneq ($(IB),1)
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
        $(call Image/mkfs/ext2)
+       $(call Image/mkfs/iso)
 else
   install: compile install-targets
        $(call Image/BuildKernel)
@@ -120,6 +127,7 @@ else
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
        $(call Image/mkfs/ext2)
+       $(call Image/mkfs/iso)
 endif
        
 ifneq ($(IB),1)