DESCRIPTION:= is obselete, so complain if it is used and use TITLE if no description...
[openwrt/svn-archive/archive.git] / include / image.mk
index fa08372007cee4f6becd5aff39d85234e9ffd00c..fea7d1ce6f37969823961abf030855995ee758a3 100644 (file)
@@ -5,6 +5,7 @@
 # See /LICENSE for more information.
 #
 
+override TARGET_BUILD=
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/host.mk
@@ -80,6 +81,12 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   endef
 endif
 
+ifeq ($(CONFIG_TARGET_ROOTFS_ISO),y) 
+  define Image/mkfs/iso 
+               $(call Image/Build,iso) 
+  endef 
+endif 
+
 
 define Image/mkfs/prepare/default
        find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
@@ -112,6 +119,7 @@ ifneq ($(IB),1)
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
        $(call Image/mkfs/ext2)
+       $(call Image/mkfs/iso)
 else
   install: compile install-targets
        $(call Image/BuildKernel)
@@ -119,6 +127,7 @@ else
        $(call Image/mkfs/squashfs)
        $(call Image/mkfs/tgz)
        $(call Image/mkfs/ext2)
+       $(call Image/mkfs/iso)
 endif
        
 ifneq ($(IB),1)