kernel build cleanup
[openwrt/svn-archive/archive.git] / include / kernel-build.mk
index 35149d768614eda67148b661a6a9744cf6b95b33..3a17182a27a2b8d9b04def3985ddbf56b7fecc73 100644 (file)
@@ -6,20 +6,43 @@
 #
 KERNEL_BUILD:=1
 
+include $(INCLUDE_DIR)/kernel-version.mk
+include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/prereq.mk
+
+LINUX_CONFIG ?= ./config/default
+
+-include $(TOPDIR)/target/linux/generic-$(KERNEL)/config-template
+-include $(LINUX_CONFIG)
+
+ifneq ($(CONFIG_ATM),)
+  FEATURES += atm
+endif
+ifneq ($(CONFIG_PCI),)
+  FEATURES += pci
+endif
+ifneq ($(CONFIG_USB),)
+  FEATURES += usb
+endif
+ifneq ($(CONFIG_PCMCIA),)
+  FEATURES += pcmcia
+endif
+ifneq ($(CONFIG_VIDEO_DEV),)
+  FEATURES += video
+endif
+
+# remove duplicates
+FEATURES:=$(sort $(FEATURES))
+
 # For target profile selection - the default set
-DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd
+DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd kmod-ipt-nathelper
 
 ifeq ($(DUMP),1)
   all: dumpinfo
 else
   all: compile
 endif
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
-
-include $(INCLUDE_DIR)/host.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-LINUX_CONFIG:=./config
 
 ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH:=um
@@ -37,6 +60,9 @@ KERNELNAME=
 ifneq (,$(findstring x86,$(BOARD)))
   KERNELNAME="bzImage"
 endif
+ifneq (,$(findstring rdc,$(BOARD)))
+  KERNELNAME="bzImage"
+endif
 ifneq (,$(findstring ppc,$(BOARD)))
   KERNELNAME="uImage"
 endif
@@ -44,25 +70,33 @@ endif
 
 define Kernel/Prepare/Default
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches 
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+       if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi
+       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+       if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi
 endef
 define Kernel/Prepare
        $(call Kernel/Prepare/Default)
 endef
 
+KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
+       CROSS_COMPILE="$(KERNEL_CROSS)" \
+       ARCH="$(LINUX_KARCH)" \
+       CONFIG_SHELL="$(BASH)"
 
 define Kernel/Configure/2.4
        $(SED) "s,\-mcpu=,\-mtune=,g;" $(LINUX_DIR)/arch/mips/Makefile
-       $(MAKE) -C $(LINUX_DIR) CROSS_COMPILE="$(KERNEL_CROSS)" CC="$(KERNEL_CC)" ARCH=$(LINUX_KARCH) oldconfig include/linux/compile.h include/linux/version.h
-       $(MAKE) -C $(LINUX_DIR) CROSS_COMPILE="$(KERNEL_CROSS)" ARCH=$(LINUX_KARCH) dep
+       $(MAKE) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" oldconfig include/linux/compile.h include/linux/version.h
+       $(MAKE) $(KERNEL_MAKEOPTS) dep
 endef
 define Kernel/Configure/2.6
-       $(MAKE) -C $(LINUX_DIR) CROSS_COMPILE="$(KERNEL_CROSS)" CC="$(KERNEL_CC)" ARCH=$(LINUX_KARCH) oldconfig prepare scripts
+       $(MAKE) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" oldconfig prepare scripts
 endef
 define Kernel/Configure/Default
-       @$(CP) $(LINUX_CONFIG) $(LINUX_DIR)/.config
-       $(call Kernel/Configure/$(KERNEL))
+       @if [ -f "./config/profile-$(PROFILE)" ]; then \
+               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template '+' $(LINUX_CONFIG) ./config/profile-$(PROFILE) > $(LINUX_DIR)/.config; \
+       else \
+               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template $(LINUX_CONFIG) > $(LINUX_DIR)/.config; \
+       fi
 endef
 define Kernel/Configure
        $(call Kernel/Configure/Default)
@@ -70,8 +104,8 @@ endef
 
 
 define Kernel/CompileModules/Default
-       $(MAKE) -j$(CONFIG_JLEVEL) -C "$(LINUX_DIR)" CROSS_COMPILE="$(KERNEL_CROSS)" CC="$(KERNEL_CC)" ARCH=$(LINUX_KARCH) modules
-       $(MAKE) -C "$(LINUX_DIR)" CROSS_COMPILE="$(KERNEL_CROSS)" CC="$(KERNEL_CC)" ARCH=$(LINUX_KARCH) DEPMOD=true INSTALL_MOD_PATH=$(KERNEL_BUILD_DIR)/modules modules_install
+       $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" modules
+       $(MAKE) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" DEPMOD=true INSTALL_MOD_PATH=$(KERNEL_BUILD_DIR)/modules modules_install
 endef
 define Kernel/CompileModules
        $(call Kernel/CompileModules/Default)
@@ -87,7 +121,7 @@ ifeq ($(KERNEL),2.6)
                echo 'CONFIG_INITRAMFS_ROOT_UID=0' >> $(LINUX_DIR)/.config
                echo 'CONFIG_INITRAMFS_ROOT_GID=0' >> $(LINUX_DIR)/.config
                mkdir -p $(BUILD_DIR)/root/etc/init.d
-               $(CP) ../generic-2.6/files/init $(BUILD_DIR)/root/
+               $(CP) $(GENERIC_PLATFORM_DIR)/files/init $(BUILD_DIR)/root/
     endef
   else
     define Kernel/SetInitramfs
@@ -100,8 +134,9 @@ ifeq ($(KERNEL),2.6)
 endif
 define Kernel/CompileImage/Default
        $(call Kernel/SetInitramfs)
-       $(MAKE) -j$(CONFIG_JLEVEL) -C $(LINUX_DIR) CROSS_COMPILE="$(KERNEL_CROSS)" CC="$(KERNEL_CC)" ARCH=$(LINUX_KARCH) $(KERNELNAME)
+       $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" $(KERNELNAME)
        $(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
+       $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
 endef
 define Kernel/CompileImage
        $(call Kernel/CompileImage/Default)
@@ -133,6 +168,7 @@ define BuildKernel
 
   $(LINUX_DIR)/.configured: $(LINUX_DIR)/.prepared $(LINUX_CONFIG)
        $(call Kernel/Configure)
+       $(call Kernel/Configure/$(KERNEL))
        touch $$@
 
   $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured
@@ -177,13 +213,25 @@ define Profile/Default
   PACKAGES:=
 endef
 
+confname=$(subst .,_,$(subst -,_,$(1)))
 define Profile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
+  $(eval $(call shexport,Profile/$(1)/Description))
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
        echo "Target-Profile-Name: $(NAME)"; \
-       echo "Target-Profile-Packages: $(PACKAGES)"; 
+       echo "Target-Profile-Packages: $(PACKAGES)"; \
+       if [ -f ./config/profile-$(1) ]; then \
+               echo "Target-Profile-Kconfig: yes"; \
+       fi; \
+       echo "Target-Profile-Description:"; \
+       getvar "$(call shvar,Profile/$(1)/Description)"; \
+       echo "@@"; \
+       echo;
+  ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
+    PROFILE=$(1)
+  endif
 endef
 
 $(eval $(call shexport,Target/Description))
@@ -191,6 +239,12 @@ $(eval $(call shexport,Target/Description))
 download: $(DL_DIR)/$(LINUX_SOURCE)
 prepare: $(LINUX_DIR)/.configured $(TMP_DIR)/.kernel.mk
 compile: $(LINUX_DIR)/.modules
+menuconfig: $(LINUX_DIR)/.prepared FORCE
+       $(call Kernel/Configure)
+       $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template $(LINUX_CONFIG) > $(LINUX_DIR)/.config
+       $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) menuconfig
+       $(SCRIPT_DIR)/config.pl '>' $(GENERIC_PLATFORM_DIR)/config-template $(LINUX_DIR)/.config > $(LINUX_CONFIG)
+
 install: $(LINUX_DIR)/.image
 
 clean: FORCE