rework parallel building to get rid of some warnings
[openwrt/svn-archive/archive.git] / include / kernel-build.mk
index 9335e1a0d5a80ed5c7f6989ed4e2a7fe5344cd47..4c6a32a42930db1879c5a94c325aae739283ca5f 100644 (file)
@@ -7,10 +7,6 @@
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/prereq.mk
 
-ifneq ($(DUMP),1)
-  override MAKEFLAGS=
-endif
-
 ifneq ($(DUMP),1)
   all: compile
 endif
@@ -81,27 +77,21 @@ define BuildKernel
        $(MAKE) -C image compile TARGET_BUILD=
 
   oldconfig menuconfig: $(STAMP_PREPARED) FORCE
+       [ -e "$(LINUX_CONFIG)" ] || touch "$(LINUX_CONFIG)"
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
        touch $(LINUX_CONFIG)
-       $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
+       $(_SINGLE)$(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
        $(SCRIPT_DIR)/kconfig.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG)
        $(Kernel/Configure)
 
   install: $(LINUX_DIR)/.image
-       TARGET_BUILD="" $(MAKE) -C image compile install
+       +$(MAKE) -C image compile install TARGET_BUILD=
 
   clean: FORCE
        rm -rf $(KERNEL_BUILD_DIR)
 
-  rebuild: FORCE
-       @$(MAKE) mostlyclean
-       @if [ -f $(LINUX_KERNEL) ]; then \
-               $(MAKE) clean; \
-       fi
-       @$(MAKE) compile
-
   image-prereq:
-       $(SUBMAKE) -s -C image prereq TARGET_BUILD=
+       @+$(NO_TRACE_MAKE) -s -C image prereq TARGET_BUILD=
 
   prereq: image-prereq