only squash owners, not permissions, when generating ext2 images
[openwrt/svn-archive/archive.git] / include / kernel-build.mk
index 55e1b82ebdc9046bf2060af9633748d20b0b3c10..6d9c9d978d17ebdf34817919c80043c40ab6bc5e 100644 (file)
@@ -33,8 +33,8 @@ ifeq ($(DUMP),1)
 else
   all: compile
 endif
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
 
+include $(INCLUDE_DIR)/kernel-version.mk
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/kernel.mk
 
@@ -56,6 +56,9 @@ KERNELNAME=
 ifneq (,$(findstring x86,$(BOARD)))
   KERNELNAME="bzImage"
 endif
+ifneq (,$(findstring rdc,$(BOARD)))
+  KERNELNAME="bzImage"
+endif
 ifneq (,$(findstring ppc,$(BOARD)))
   KERNELNAME="uImage"
 endif
@@ -63,7 +66,7 @@ endif
 
 define Kernel/Prepare/Default
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches 
+       [ -d $(GENERIC_PLATFORM_DIR)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches 
        [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
 endef
 define Kernel/Prepare
@@ -110,7 +113,7 @@ ifeq ($(KERNEL),2.6)
                echo 'CONFIG_INITRAMFS_ROOT_UID=0' >> $(LINUX_DIR)/.config
                echo 'CONFIG_INITRAMFS_ROOT_GID=0' >> $(LINUX_DIR)/.config
                mkdir -p $(BUILD_DIR)/root/etc/init.d
-               $(CP) $(TOPDIR)/target/linux/generic-2.6/files/init $(BUILD_DIR)/root/
+               $(CP) $(GENERIC_PLATFORM_DIR)/files/init $(BUILD_DIR)/root/
     endef
   else
     define Kernel/SetInitramfs