Also load compat_ioctl32 for V4L devices to load
[openwrt/svn-archive/archive.git] / include / kernel-build.mk
index 3a17182a27a2b8d9b04def3985ddbf56b7fecc73..71b9d8000fc2e213deb4dec41c21a963871747b5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -25,7 +25,7 @@ endif
 ifneq ($(CONFIG_USB),)
   FEATURES += usb
 endif
-ifneq ($(CONFIG_PCMCIA),)
+ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
   FEATURES += pcmcia
 endif
 ifneq ($(CONFIG_VIDEO_DEV),)
@@ -35,9 +35,6 @@ endif
 # remove duplicates
 FEATURES:=$(sort $(FEATURES))
 
-# For target profile selection - the default set
-DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd kmod-ipt-nathelper
-
 ifeq ($(DUMP),1)
   all: dumpinfo
 else
@@ -56,99 +53,27 @@ else
   )
 endif
 
-KERNELNAME=
-ifneq (,$(findstring x86,$(BOARD)))
-  KERNELNAME="bzImage"
-endif
-ifneq (,$(findstring rdc,$(BOARD)))
-  KERNELNAME="bzImage"
-endif
-ifneq (,$(findstring ppc,$(BOARD)))
-  KERNELNAME="uImage"
-endif
-
+STAMP_PREPARED:=$(LINUX_DIR)/.prepared
+STAMP_CONFIGURED:=$(LINUX_DIR)/.configured
+include $(INCLUDE_DIR)/quilt.mk
+include $(INCLUDE_DIR)/kernel-defaults.mk
 
-define Kernel/Prepare/Default
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi
-       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
-       if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi
-endef
 define Kernel/Prepare
        $(call Kernel/Prepare/Default)
 endef
 
-KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
-       CROSS_COMPILE="$(KERNEL_CROSS)" \
-       ARCH="$(LINUX_KARCH)" \
-       CONFIG_SHELL="$(BASH)"
-
-define Kernel/Configure/2.4
-       $(SED) "s,\-mcpu=,\-mtune=,g;" $(LINUX_DIR)/arch/mips/Makefile
-       $(MAKE) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" oldconfig include/linux/compile.h include/linux/version.h
-       $(MAKE) $(KERNEL_MAKEOPTS) dep
-endef
-define Kernel/Configure/2.6
-       $(MAKE) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" oldconfig prepare scripts
-endef
-define Kernel/Configure/Default
-       @if [ -f "./config/profile-$(PROFILE)" ]; then \
-               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template '+' $(LINUX_CONFIG) ./config/profile-$(PROFILE) > $(LINUX_DIR)/.config; \
-       else \
-               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template $(LINUX_CONFIG) > $(LINUX_DIR)/.config; \
-       fi
-endef
 define Kernel/Configure
        $(call Kernel/Configure/Default)
 endef
 
-
-define Kernel/CompileModules/Default
-       $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" modules
-       $(MAKE) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" DEPMOD=true INSTALL_MOD_PATH=$(KERNEL_BUILD_DIR)/modules modules_install
-endef
 define Kernel/CompileModules
        $(call Kernel/CompileModules/Default)
 endef
 
-
-ifeq ($(KERNEL),2.6)
-  ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-    define Kernel/SetInitramfs
-               mv $(LINUX_DIR)/.config $(LINUX_DIR)/.config.old
-               grep -v INITRAMFS $(LINUX_DIR)/.config.old > $(LINUX_DIR)/.config
-               echo 'CONFIG_INITRAMFS_SOURCE="../../root"' >> $(LINUX_DIR)/.config
-               echo 'CONFIG_INITRAMFS_ROOT_UID=0' >> $(LINUX_DIR)/.config
-               echo 'CONFIG_INITRAMFS_ROOT_GID=0' >> $(LINUX_DIR)/.config
-               mkdir -p $(BUILD_DIR)/root/etc/init.d
-               $(CP) $(GENERIC_PLATFORM_DIR)/files/init $(BUILD_DIR)/root/
-    endef
-  else
-    define Kernel/SetInitramfs
-               mv $(LINUX_DIR)/.config $(LINUX_DIR)/.config.old
-               grep -v INITRAMFS $(LINUX_DIR)/.config.old > $(LINUX_DIR)/.config
-               rm -f $(BUILD_DIR)/root/init $(BUILD_DIR)/root/etc/init.d/S00initramfs
-               echo 'CONFIG_INITRAMFS_SOURCE=""' >> $(LINUX_DIR)/.config
-    endef
-  endif
-endif
-define Kernel/CompileImage/Default
-       $(call Kernel/SetInitramfs)
-       $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" $(KERNELNAME)
-       $(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
-       $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
-endef
 define Kernel/CompileImage
        $(call Kernel/CompileImage/Default)
 endef
 
-define Kernel/Clean/Default
-       rm -f $(LINUX_DIR)/.linux-compile
-       rm -f $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/.configured
-       rm -f $(LINUX_KERNEL)
-       $(MAKE) -C $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION) clean
-endef
-
 define Kernel/Clean
        $(call Kernel/Clean/Default)
 endef
@@ -160,21 +85,17 @@ define BuildKernel
                $(SCRIPT_DIR)/download.pl $(DL_DIR) $(LINUX_SOURCE) $(LINUX_KERNEL_MD5SUM) $(LINUX_SITE)
   endif
 
-  $(LINUX_DIR)/.prepared: $(DL_DIR)/$(LINUX_SOURCE)
+  $(STAMP_PREPARED): $(DL_DIR)/$(LINUX_SOURCE)
        -rm -rf $(KERNEL_BUILD_DIR)
        -mkdir -p $(KERNEL_BUILD_DIR)
        $(call Kernel/Prepare)
        touch $$@
 
-  $(LINUX_DIR)/.configured: $(LINUX_DIR)/.prepared $(LINUX_CONFIG)
+  $(STAMP_CONFIGURED): $(LINUX_DIR)/.prepared $(LINUX_CONFIG)
        $(call Kernel/Configure)
-       $(call Kernel/Configure/$(KERNEL))
        touch $$@
 
-  $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured
-       rm -rf $(KERNEL_BUILD_DIR)/modules
-       @rm -f $(BUILD_DIR)/linux
-       ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION) $(BUILD_DIR)/linux
+  $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured $(LINUX_DIR)/.config FORCE
        $(call Kernel/CompileModules)
        touch $$@
 
@@ -217,6 +138,7 @@ confname=$(subst .,_,$(subst -,_,$(1)))
 define Profile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
+  $(eval $(call shexport,Profile/$(1)/Config))
   $(eval $(call shexport,Profile/$(1)/Description))
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
@@ -225,6 +147,9 @@ define Profile
        if [ -f ./config/profile-$(1) ]; then \
                echo "Target-Profile-Kconfig: yes"; \
        fi; \
+       echo "Target-Profile-Config: "; \
+       getvar "$(call shvar,Profile/$(1)/Config)"; \
+       echo "@@"; \
        echo "Target-Profile-Description:"; \
        getvar "$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
@@ -237,7 +162,7 @@ endef
 $(eval $(call shexport,Target/Description))
 
 download: $(DL_DIR)/$(LINUX_SOURCE)
-prepare: $(LINUX_DIR)/.configured $(TMP_DIR)/.kernel.mk
+prepare: $(LINUX_DIR)/.configured
 compile: $(LINUX_DIR)/.modules
 menuconfig: $(LINUX_DIR)/.prepared FORCE
        $(call Kernel/Configure)