use separate sysctl.conf files for 2.4 and 2.6 - fixes some boot message spam
[openwrt/svn-archive/archive.git] / include / kernel-build.mk
index d344702dda59fff0aac97217c32020dde15521cf..9037b5ced043ccc656769cdce0a17122290e4c53 100644 (file)
@@ -92,7 +92,7 @@ define BuildKernel
        $(call Kernel/Configure)
        touch $$@
 
-  $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured $(LINUX_DIR)/.config
+  $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured $(LINUX_DIR)/.config FORCE
        $(call Kernel/CompileModules)
        touch $$@
 
@@ -159,7 +159,7 @@ endef
 $(eval $(call shexport,Target/Description))
 
 download: $(DL_DIR)/$(LINUX_SOURCE)
-prepare: $(LINUX_DIR)/.configured $(TMP_DIR)/.kernel.mk
+prepare: $(LINUX_DIR)/.configured
 compile: $(LINUX_DIR)/.modules
 menuconfig: $(LINUX_DIR)/.prepared FORCE
        $(call Kernel/Configure)