add descriptions to the broadcom target profiles and export them to the target metada...
[openwrt/svn-archive/archive.git] / include / kernel-build.mk
index 6d9c9d978d17ebdf34817919c80043c40ab6bc5e..9a1e36328b74e0d605dd4b2365a7afdbf065806b 100644 (file)
@@ -206,10 +206,15 @@ endef
 define Profile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
+  $(eval $(call shexport,Profile/$(1)/Description))
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
        echo "Target-Profile-Name: $(NAME)"; \
-       echo "Target-Profile-Packages: $(PACKAGES)"; 
+       echo "Target-Profile-Packages: $(PACKAGES)"; \
+       echo "Target-Profile-Description:"; \
+       getvar "$(call shvar,Profile/$(1)/Description)"; \
+       echo "@@"; \
+       echo;
 endef
 
 $(eval $(call shexport,Target/Description))