fix pcmcia/pccard build defaults
[openwrt/svn-archive/archive.git] / include / kernel-build.mk
index a89d9d9f2500be28f80e1d4c4fb8e0ee60bc11af..e3c532cd1d7c3f73d64127b8635257ee780d6109 100644 (file)
@@ -25,7 +25,7 @@ endif
 ifneq ($(CONFIG_USB),)
   FEATURES += usb
 endif
-ifneq ($(CONFIG_PCMCIA),)
+ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
   FEATURES += pcmcia
 endif
 ifneq ($(CONFIG_VIDEO_DEV),)
@@ -92,10 +92,7 @@ define BuildKernel
        $(call Kernel/Configure)
        touch $$@
 
-  $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured
-       rm -rf $(KERNEL_BUILD_DIR)/modules
-       @rm -f $(BUILD_DIR)/linux
-       ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION) $(BUILD_DIR)/linux
+  $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured $(LINUX_DIR)/.config FORCE
        $(call Kernel/CompileModules)
        touch $$@
 
@@ -162,7 +159,7 @@ endef
 $(eval $(call shexport,Target/Description))
 
 download: $(DL_DIR)/$(LINUX_SOURCE)
-prepare: $(LINUX_DIR)/.configured $(TMP_DIR)/.kernel.mk
+prepare: $(LINUX_DIR)/.configured
 compile: $(LINUX_DIR)/.modules
 menuconfig: $(LINUX_DIR)/.prepared FORCE
        $(call Kernel/Configure)