[brcm63xx] Profiles: Move wpad-mini to the profiles that use it, rather than default...
[openwrt/svn-archive/archive.git] / include / kernel-version.mk
index f019897bebf44ab0b642b7b16fe5e205aa7ecd4d..21a1e034e81942fce58c5a5855d61d2bc613c428 100644 (file)
@@ -1,32 +1,30 @@
 # Use the default kernel version if the Makefile doesn't override it
 
-ifeq ($(KERNEL),2.4)
-  LINUX_VERSION?=2.4.37.5
-else
-  LINUX_VERSION?=2.6.21.7
-endif
 LINUX_RELEASE?=1
 
-ifeq ($(LINUX_VERSION),2.4.37.5)
-  LINUX_KERNEL_MD5SUM:=cb221187422acaf6c63a40c646e5e476
-endif
-ifeq ($(LINUX_VERSION),2.6.21.7)
-  LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
-endif
 ifeq ($(LINUX_VERSION),2.6.25.20)
   LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
 endif
-ifeq ($(LINUX_VERSION),2.6.27.34)
-  LINUX_KERNEL_MD5SUM:=4036300a95c62d6969de674901b26145
+ifeq ($(LINUX_VERSION),2.6.30.10)
+  LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
+endif
+ifeq ($(LINUX_VERSION),2.6.31.14)
+  LINUX_KERNEL_MD5SUM:=3e7feb224197d8e174a90dd3759979fd
+endif
+ifeq ($(LINUX_VERSION),2.6.32.26)
+  LINUX_KERNEL_MD5SUM:=bdb37b8e48aaf33d9bd6e2af3ae2f1ea
+endif
+ifeq ($(LINUX_VERSION),2.6.33.7)
+  LINUX_KERNEL_MD5SUM:=2cea51deeaa0620a07d005ec3b148f06
 endif
-ifeq ($(LINUX_VERSION),2.6.28.10)
-  LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
+ifeq ($(LINUX_VERSION),2.6.34.7)
+  LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
 endif
-ifeq ($(LINUX_VERSION),2.6.30.8)
-  LINUX_KERNEL_MD5SUM:=76b8397bfb477788b26c834f71e27df6
+ifeq ($(LINUX_VERSION),2.6.35.9)
+  LINUX_KERNEL_MD5SUM:=18d339e9229560e73c4249dffdc3fd90
 endif
-ifeq ($(LINUX_VERSION),2.6.31.1)
-  LINUX_KERNEL_MD5SUM:=8077cd7f7c1cdeb6aef3872441ae5294
+ifeq ($(LINUX_VERSION),2.6.36.1)
+  LINUX_KERNEL_MD5SUM:=0f1398ad1fcfc14f2420010bc8a03ca9
 endif
 
 # disable the md5sum check for unknown kernel versions