[kernel] switch to 2.6.27.30
[openwrt/svn-archive/archive.git] / include / kernel-version.mk
index 96051e055bd822151dce01087adc4bcd39c40437..70b2ab042d58104dd142d4cb27ebc5b716dbd97d 100644 (file)
@@ -1,14 +1,14 @@
 # Use the default kernel version if the Makefile doesn't override it
 
 ifeq ($(KERNEL),2.4)
-  LINUX_VERSION?=2.4.37.4
+  LINUX_VERSION?=2.4.37.5
 else
   LINUX_VERSION?=2.6.21.7
 endif
 LINUX_RELEASE?=1
 
-ifeq ($(LINUX_VERSION),2.4.37.4)
-  LINUX_KERNEL_MD5SUM:=
+ifeq ($(LINUX_VERSION),2.4.37.5)
+  LINUX_KERNEL_MD5SUM:=cb221187422acaf6c63a40c646e5e476
 endif
 ifeq ($(LINUX_VERSION),2.6.21.7)
   LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
@@ -16,14 +16,14 @@ endif
 ifeq ($(LINUX_VERSION),2.6.25.20)
   LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
 endif
-ifeq ($(LINUX_VERSION),2.6.27.29)
-  LINUX_KERNEL_MD5SUM:=ab6991ee42603a4dbfba7956a54c89a4
+ifeq ($(LINUX_VERSION),2.6.27.30)
+  LINUX_KERNEL_MD5SUM:=f925e467e1a6168ac2a4a376d76571c3
 endif
 ifeq ($(LINUX_VERSION),2.6.28.10)
   LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
 endif
-ifeq ($(LINUX_VERSION),2.6.30.3)
-  LINUX_KERNEL_MD5SUM:=5499e1fd246215d65fc7068cfb040406
+ifeq ($(LINUX_VERSION),2.6.30.4)
+  LINUX_KERNEL_MD5SUM:=ac05e32764368af7eff79c5e3df65efb
 endif
 
 # disable the md5sum check for unknown kernel versions