[kernel] switch to 2.6.27.30
[openwrt/svn-archive/archive.git] / include / kernel-version.mk
index af457a248570c00090b99049845e4ccf3b57f6b1..70b2ab042d58104dd142d4cb27ebc5b716dbd97d 100644 (file)
@@ -1,15 +1,37 @@
 # Use the default kernel version if the Makefile doesn't override it
 
-ifeq ($(LINUX_VERSION),)
-  ifeq ($(KERNEL),2.4)
-    LINUX_VERSION:=2.4.33.4
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
-  else
-    LINUX_VERSION:=2.6.19.1
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-  endif
-endif
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+ifeq ($(KERNEL),2.4)
+  LINUX_VERSION?=2.4.37.5
+else
+  LINUX_VERSION?=2.6.21.7
+endif
+LINUX_RELEASE?=1
+
+ifeq ($(LINUX_VERSION),2.4.37.5)
+  LINUX_KERNEL_MD5SUM:=cb221187422acaf6c63a40c646e5e476
+endif
+ifeq ($(LINUX_VERSION),2.6.21.7)
+  LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
+endif
+ifeq ($(LINUX_VERSION),2.6.25.20)
+  LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
+endif
+ifeq ($(LINUX_VERSION),2.6.27.30)
+  LINUX_KERNEL_MD5SUM:=f925e467e1a6168ac2a4a376d76571c3
+endif
+ifeq ($(LINUX_VERSION),2.6.28.10)
+  LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
+endif
+ifeq ($(LINUX_VERSION),2.6.30.4)
+  LINUX_KERNEL_MD5SUM:=ac05e32764368af7eff79c5e3df65efb
+endif
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM?=x
+
+split_version=$(subst ., ,$(1))
+merge_version=$(subst $(space),.,$(1))
+KERNEL_BASE=$(firstword $(subst -, ,$(LINUX_VERSION)))
+KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE))))
+KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(KERNEL_BASE))))