with no users left, remove support for 2.6.21
[openwrt/svn-archive/archive.git] / include / kernel-version.mk
index a6a7c6729c8d4e6f026b2022343219459ed46126..b2810ce75ff389bbb9a52007e03e10a777c559f9 100644 (file)
@@ -1,29 +1,24 @@
 # Use the default kernel version if the Makefile doesn't override it
 
 ifeq ($(KERNEL),2.4)
-  LINUX_VERSION?=2.4.37.4
-else
-  LINUX_VERSION?=2.6.21.7
+  LINUX_VERSION?=2.4.37.5
 endif
 LINUX_RELEASE?=1
 
-ifeq ($(LINUX_VERSION),2.4.37.4)
-  LINUX_KERNEL_MD5SUM:=
-endif
-ifeq ($(LINUX_VERSION),2.6.21.7)
-  LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
+ifeq ($(LINUX_VERSION),2.4.37.5)
+  LINUX_KERNEL_MD5SUM:=cb221187422acaf6c63a40c646e5e476
 endif
 ifeq ($(LINUX_VERSION),2.6.25.20)
   LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
 endif
-ifeq ($(LINUX_VERSION),2.6.27.28)
-  LINUX_KERNEL_MD5SUM:=f05cd17ba8ee19924c9c473219fbaa9b
+ifeq ($(LINUX_VERSION),2.6.30.10)
+  LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
 endif
-ifeq ($(LINUX_VERSION),2.6.28.10)
-  LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
+ifeq ($(LINUX_VERSION),2.6.31.12)
+  LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
 endif
-ifeq ($(LINUX_VERSION),2.6.30.3)
-  LINUX_KERNEL_MD5SUM:=5499e1fd246215d65fc7068cfb040406
+ifeq ($(LINUX_VERSION),2.6.32.7)
+  LINUX_KERNEL_MD5SUM:=d59aca06609cedabe4d6d161d9f11113
 endif
 
 # disable the md5sum check for unknown kernel versions