prevent kernel.mk from defining PATCH_DIR and FILES_DIR for regular packages
[openwrt/svn-archive/archive.git] / include / kernel-version.mk
index 4ab4bbe68ab0bf3a1cb4ba9a7298e68ce7ce98fd..e4f0b486f01a7f1ed2c76d472ab928ad2aa31fe6 100644 (file)
@@ -1,17 +1,12 @@
 # Use the default kernel version if the Makefile doesn't override it
 
 ifeq ($(KERNEL),2.4)
-  LINUX_VERSION?=2.4.37.5
-else
-  LINUX_VERSION?=2.6.21.7
+  LINUX_VERSION?=2.4.37.9
 endif
 LINUX_RELEASE?=1
 
-ifeq ($(LINUX_VERSION),2.4.37.5)
-  LINUX_KERNEL_MD5SUM:=cb221187422acaf6c63a40c646e5e476
-endif
-ifeq ($(LINUX_VERSION),2.6.21.7)
-  LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
+ifeq ($(LINUX_VERSION),2.4.37.9)
+  LINUX_KERNEL_MD5SUM:=b85b8962840c13f17f944e7b1890f8f8
 endif
 ifeq ($(LINUX_VERSION),2.6.25.20)
   LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
@@ -19,11 +14,17 @@ endif
 ifeq ($(LINUX_VERSION),2.6.30.10)
   LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
 endif
-ifeq ($(LINUX_VERSION),2.6.31.11)
-  LINUX_KERNEL_MD5SUM:=39e34c9a6439bcd4c088abe631302a99
+ifeq ($(LINUX_VERSION),2.6.31.12)
+  LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
+endif
+ifeq ($(LINUX_VERSION),2.6.32.10)
+  LINUX_KERNEL_MD5SUM:=5d996507ad482a3a8c8e6b2d48e7994b
+endif
+ifeq ($(LINUX_VERSION),2.6.33)
+  LINUX_KERNEL_MD5SUM:=c3883760b18d50e8d78819c54d579b00
 endif
-ifeq ($(LINUX_VERSION),2.6.32.3)
-  LINUX_KERNEL_MD5SUM:=730045c2c7f7e6618db3c4d4d7094853
+ifeq ($(LINUX_VERSION),2.6.33.1)
+  LINUX_KERNEL_MD5SUM:=73b514ec918b88a45656be191b1ee226
 endif
 
 # disable the md5sum check for unknown kernel versions