[8.09] openssl: fix 4 DoS vulnerabilities in DTLS
[openwrt/svn-archive/archive.git] / include / kernel.mk
index b80c3b63ff8ffc6b6c7aea3d44055d43915ddde4..5232148a6b4fa833faa56183d1aaa3df24fa302e 100644 (file)
@@ -120,7 +120,15 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
-  ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
+  ifdef KernelPackage/$(1)/config
+    define Package/kmod-$(1)/config
+$(call KernelPackage/$(1)/config)
+    endef
+  endif
+
+  $(STAMP_BUILT): $(LINUX_DIR)/.config
+
+  ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)