get rid of one more $(shell) instance
[openwrt/svn-archive/archive.git] / include / kernel.mk
index 748605705289425a6363d8855557476845253b4c..8b98369b4bf02c469d2142082639c97a521195ba 100644 (file)
@@ -23,14 +23,15 @@ else
   endif
 
   ifneq (,$(findstring uml,$(BOARD)))
-    KERNEL_CC:=$(HOSTCC)
-    KERNEL_CROSS:=
+    KERNEL_CC?=$(HOSTCC)
+    KERNEL_CROSS?=
   else
-    KERNEL_CC:=$(TARGET_CC)
-    KERNEL_CROSS:=$(TARGET_CROSS)
+    KERNEL_CC?=$(TARGET_CC)
+    KERNEL_CROSS?=$(TARGET_CROSS)
   endif
 
-  PATCH_DIR ?= ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
+  PATCH_DIR ?= ./patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
+  FILES_DIR ?= $(foreach dir,$(wildcard ./files ./files-$(KERNEL_PATCHVER)),"$(dir)")
   KERNEL_BUILD_DIR ?= $(BUILD_DIR_BASE)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
   LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
 
@@ -49,15 +50,11 @@ else
 endif
 
 ifneq (,$(findstring uml,$(BOARD)))
-  LINUX_KARCH:=um
+  LINUX_KARCH=um
 else
-  LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-       -e 's/mipsel/mips/' \
-       -e 's/mipseb/mips/' \
-       -e 's/powerpc/ppc/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/armeb/arm/' \
-  )
+  ifeq (,$(LINUX_KARCH))
+    LINUX_KARCH=$(strip $(subst i386,x86,$(subst armeb,arm,$(subst mipsel,mips,$(subst sh2,sh,$(subst sh3,sh,$(subst sh4,sh,$(ARCH))))))))
+  endif
 endif
 
 
@@ -87,7 +84,16 @@ define ModuleAutoLoad
                chmod 0755 $(2)/CONTROL/postinst; \
        fi
 endef
+
+ifeq ($(DUMP)$(TARGET_BUILD),)
+  -include $(LINUX_DIR)/.config
+endif
+
+define KernelPackage/depends
+  $(STAMP_BUILT): $(LINUX_DIR)/.config
+  define KernelPackage/depends
+  endef
+endef
 
 define KernelPackage
   NAME:=$(1)
@@ -115,7 +121,15 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
-  ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
+  ifdef KernelPackage/$(1)/config
+    define Package/kmod-$(1)/config
+$(call KernelPackage/$(1)/config)
+    endef
+  endif
+
+  $(call KernelPackage/depends)
+
+  ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
@@ -140,3 +154,11 @@ define AutoLoad
   add_module $(1) "$(2)";
 endef
 
+ifdef DUMP
+  CompareKernelPatchVer=0
+else
+  define CompareKernelPatchVer
+    $(shell [ $$(echo $(1) | tr . 0) -$(2) $$(echo $(3) | tr . 0) ] && echo 1 || echo 0)
+  endef
+endif
+