don't replace powerpc arch with ppc
[openwrt/svn-archive/archive.git] / include / kernel.mk
index b2a7476aa017b3d4dbc9c9e457be5c289f7ace32..f9baeef0ac3daa5505344310b9656c49c960931a 100644 (file)
@@ -43,19 +43,22 @@ else
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING) \
 
-  PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  ifneq ($(TARGET_BUILD),1)
+    PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  endif
 endif
 
 ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH:=um
 else
-  LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-       -e 's/mipsel/mips/' \
-       -e 's/mipseb/mips/' \
-       -e 's/powerpc/ppc/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/armeb/arm/' \
-  )
+  ifeq (,$(LINUX_KARCH))
+    LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+         -e 's/mipsel/mips/' \
+         -e 's/mipseb/mips/' \
+         -e 's/sh[234]/sh/' \
+         -e 's/armeb/arm/' \
+    )
+  endif
 endif
 
 
@@ -113,8 +116,7 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
-  # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
-  ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
+  ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)