netifd: add IPIP tunnel support (thx Hans Dedecker)
[openwrt/svn-archive/archive.git] / include / package-bin.mk
index 96c1aeffcfb0b59c1d4811b75288de3a1e28df1d..c6cb9caf41dfdc220178ffc4b9694aaff270ff3b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@ ifeq ($(DUMP),)
   define BuildTarget/bin
     ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
     ifdef Package/$(1)/install
-      ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
+      ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
         compile: install-bin-$(1)
       else
         compile: $(1)-disabled
         $(1)-disabled:
-               @echo "WARNING: skipping $(1) -- package not selected"
+               @echo "WARNING: skipping $(1) -- package not selected" >&2
       endif
     endif
     endif