kernel: update 3.18 to 3.18.17
[openwrt/svn-archive/archive.git] / include / package-bin.mk
index 6ee7aed6217087df154eff60a318fe36c2688512..e5224517f8ebbb4b5c24b6a09c719f6abf08a514 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,15 +7,17 @@
 
 ifeq ($(DUMP),)
   define BuildTarget/bin
+    ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
     ifdef Package/$(1)/install
-      ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
+      ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
         compile: install-bin-$(1)
       else
         compile: $(1)-disabled
         $(1)-disabled:
-               @echo "WARNING: skipping $(1) -- package not selected"
+               @echo "WARNING: skipping $(1) -- package not selected" >&2
       endif
     endif
+    endif
 
     install-bin-$(1): $(STAMP_BUILT)
          rm -rf $(BIN_DIR)/$(1)