build: remove SourceFile and SourceURL from opkg metadata - they are useless without...
[openwrt/svn-archive/archive.git] / include / package-ipkg.mk
index 696de156cfa98259f0d9754b8fee965f81a137b6..043431c349c73a497e62274d4acb799ec632f902 100644 (file)
@@ -64,8 +64,8 @@ ifneq ($(PKG_NAME),toolchain)
                                echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
                done; \
                if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \
-                       echo "Package $(1) is missing dependencies for the following libraries:"; \
-                       cat "$(PKG_INFO_DIR)/$(1).missing"; \
+                       echo "Package $(1) is missing dependencies for the following libraries:" >&2; \
+                       cat "$(PKG_INFO_DIR)/$(1).missing" >&2; \
                        false; \
                fi; \
        )
@@ -152,8 +152,6 @@ ifeq ($(DUMP),)
                [ -z "$$$$DEPENDS" ] || echo "Depends: $$$$DEPENDS"; \
                $(if $(PROVIDES), echo "Provides: $(PROVIDES)"; ) \
                echo "Source: $(SOURCE)"; \
-               $(if $(PKG_SOURCE), echo "SourceFile: $(PKG_SOURCE)"; ) \
-               $(if $(PKG_SOURCE_URL), echo "SourceURL: $(PKG_SOURCE_URL)"; ) \
                $(if $(PKG_LICENSE), echo "License: $(PKG_LICENSE)"; ) \
                $(if $(PKG_LICENSE_FILES), echo "LicenseFiles: $(PKG_LICENSE_FILES)"; ) \
                echo "Section: $(SECTION)"; \