ixp4xx: add back the mac handling fix - seems like it wasn't the cause for the ethern...
[openwrt/svn-archive/archive.git] / include / package-ipkg.mk
index ac6912844b029300318035a6523fef094ef1dd4a..597f5f87c350b5cd6d2f2b757affcd724fe10533 100644 (file)
@@ -63,9 +63,9 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   | xargs -r rm -rf
-       -find $$(IDIR_$(1)) -name .svn  | xargs -r rm -rf
-       -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
+       -find $$(IDIR_$(1)) -name CVS   | $(XARGS) rm -rf
+       -find $$(IDIR_$(1)) -name .svn  | $(XARGS) rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | $(XARGS) rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false 
@@ -78,7 +78,7 @@ ifeq ($(DUMP),)
 
     clean: $(1)-clean
 
-    $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
+    $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
        -@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
        @touch $$@