revert find | xargs => find | exec changes - this is completely unnecessary and intro...
[openwrt/svn-archive/archive.git] / include / package-ipkg.mk
index 8b317065bfd4bf04ab20ac051f4c6e2fb53e72a3..86c802289c34d38556a6360243657cac18ca5043 100644 (file)
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   -exec rm -rf {} +
-       -find $$(IDIR_$(1)) -name .svn  -exec rm -rf {} +
-       -find $$(IDIR_$(1)) -name '.#*' -exec rm -f  {} +
+       -find $$(IDIR_$(1)) -name CVS   | xargs -r rm -rf
+       -find $$(IDIR_$(1)) -name .svn  | xargs -r rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false