revert find | xargs => find | exec changes - this is completely unnecessary and intro...
[openwrt/svn-archive/archive.git] / include / package-ipkg.mk
index 8d6f1956f8f2a9c5f4d73cff92b70c854f2f0312..86c802289c34d38556a6360243657cac18ca5043 100644 (file)
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   | xargs rm -rf
-       -find $$(IDIR_$(1)) -name .svn  | xargs rm -rf
-       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
+       -find $$(IDIR_$(1)) -name CVS   | xargs -r rm -rf
+       -find $$(IDIR_$(1)) -name .svn  | xargs -r rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false