fix conditional depends in ipkg control files
[openwrt/svn-archive/archive.git] / include / package-ipkg.mk
index de9798413d3a33a465c7e77c749628058e487931..c5d4916c2cd59f0ed2a3a0e8761a72d7d28abee2 100644 (file)
@@ -25,7 +25,8 @@ endef
 dep_split=$(subst :,$(space),$(1))
 dep_confvar=CONFIG_$(word 1,$(call dep_split,$(1)))
 dep_val=$(word 2,$(call dep_split,$(1)))
-filter_deps=$(foreach dep,$(1),$(if $(findstring :,$(dep)),$(if $($(call dep_confvar,$(dep))),$(call dep_val,$(dep))),$(dep)))
+strip_deps=$(strip $(subst +,,$(filter-out @%,$(1))))
+filter_deps=$(foreach dep,$(call strip_deps,$(1)),$(if $(findstring :,$(dep)),$(if $($(call dep_confvar,$(dep))),$(call dep_val,$(dep))),$(dep)))
 
 ifeq ($(DUMP),)
   define BuildTarget/ipkg
@@ -47,7 +48,7 @@ ifeq ($(DUMP),)
       endif
     endif
 
-    IDEPEND_$(1):=$$(call filter_deps,$$(strip $$(DEPENDS)))
+    IDEPEND_$(1):=$$(call filter_deps,$$(DEPENDS))
   
     $(eval $(call BuildIPKGVariable,$(1),conffiles))
     $(eval $(call BuildIPKGVariable,$(1),preinst))