allow package directories to override the path to configure
[openwrt/svn-archive/archive.git] / include / package.mk
index 1a424e259f9ce8fc4e55e7abc4e199245ddf8fcd..1edac0e0acd1f8813cbe8d79c371d9ff0c944f2f 100644 (file)
@@ -14,17 +14,9 @@ include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 
+PKG_CONFIG_PATH:=.
 export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
 
-define shvar
-V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
-endef
-
-define shexport
-$(call shvar,$(1))=$$(call $(1))
-export $(call shvar,$(1))
-endef
-
 define Build/DefaultTargets
   ifeq ($(DUMP),)
     ifeq ($(CONFIG_AUTOREBUILD),y)
@@ -136,7 +128,7 @@ define BuildPackage
       install-targets: $$(INFO_$(1))
     endif
 
-    ifneq ($(CONFIG_PACKAGE_$(1)),)
+    ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER)$(SDK),)
       compile-targets: $$(IPKG_$(1))
     else
       compile-targets: $(1)-disabled
@@ -152,31 +144,35 @@ define BuildPackage
   IDEPEND_$(1):=$$(strip $$(DEPENDS))
 
   ifneq ($(DUMP),)
-    DUMPINFO += \
+    dumpinfo: dumpinfo-$(1)
+    dumpinfo-$(1): FORCE
+               @$$(DUMPINFO_$(call shvar,$(1)))
+               
+    DUMPINFO_$(call shvar,$(1)) += \
        echo "Package: $(1)"; 
 
     ifneq ($(MENU),)
-      DUMPINFO += \
+      DUMPINFO_$(call shvar,$(1)) += \
        echo "Menu: $(MENU)";
     endif
 
     ifneq ($(SUBMENU),)
-      DUMPINFO += \
+      DUMPINFO_$(call shvar,$(1)) += \
        echo "Submenu: $(SUBMENU)";
       ifneq ($(SUBMENUDEP),)
-        DUMPINFO += \
+        DUMPINFO_$(call shvar,$(1)) += \
          echo "Submenu-Depends: $(SUBMENUDEP)";
       endif
     endif
 
     ifneq ($(DEFAULT),)
-      DUMPINFO += \
+      DUMPINFO_$(call shvar,$(1)) += \
        echo "Default: $(DEFAULT)";
     endif
 
        $(call shexport,Package/$(1)/description)
 
-    DUMPINFO += \
+    DUMPINFO_$(call shvar,$(1)) += \
        if [ "$$$$PREREQ_CHECK" = 1 ]; then echo "Prereq-Check: 1"; fi; \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
@@ -188,22 +184,25 @@ define BuildPackage
                echo -n "Description: "; \
                getvar $(call shvar,Package/$(1)/description); \
        else \
-               echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+               echo "Description: $(patsubst \\,\\\\,$(DESCRIPTION))" | perl -ne 's/\\/\n/g, print'; \
        fi;
        
     ifneq ($(URL),)
-      DUMPINFO += \
+      DUMPINFO_$(call shvar,$(1)) += \
                echo; \
                echo "$(URL)";
     endif
        
-       DUMPINFO += \
+       DUMPINFO_$(call shvar,$(1)) += \
                echo "@@";
 
        $(call shexport,Package/$(1)/config)
-       DUMPINFO += \
-               if isset $(call shvar,Package/$(1)/config); then echo "Config: "; getvar $(call shvar,Package/$(1)/config); fi; \
-               echo "@@";
+       DUMPINFO_$(call shvar,$(1)) += \
+               if isset $(call shvar,Package/$(1)/config); then \
+                       echo "Config: "; \
+                       getvar $(call shvar,Package/$(1)/config); \
+                       echo "@@"; \
+               fi;
   
   endif
 
@@ -217,11 +216,11 @@ define BuildPackage
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
        ( \
-               DEPENDS=; \
+               DEPENDS='$(EXTRA_DEPENDS)'; \
                for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
                        DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
                done; \
-               echo "Depends: $(EXTRA_DEPENDS) $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
        )
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
@@ -259,7 +258,7 @@ define BuildPackage
   $$(eval $$(call Build/DefaultTargets,$(1)))
 
   ifdef Package/$(1)/install
-    ifneq ($$(CONFIG_PACKAGE_$(1)),)
+    ifneq ($$(CONFIG_PACKAGE_$(1))$(DEVELOPER)$(SDK),)
       ifneq ($(MAKECMDGOALS),prereq)
         ifneq ($(DUMP),1)
           ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
@@ -290,16 +289,6 @@ define Build/Prepare
 endef
 
 define Build/Configure/Default
-       (cd $(PKG_BUILD_DIR) ; \
-               [ -e configure.in ] && touch configure.in ; \
-               [ -e aclocal.m4 ] && touch aclocal.m4 ; \
-               [ -e Makefile.in ] && touch Makefile.in ; \
-               [ -e configure ] && touch configure ; \
-               [ -e acinclude.m4 ] && touch acinclude.m4 ; \
-               [ -e config.h.in ] && touch config.h.in ; \
-               [ -e configure.ac ] && touch configure.ac ; \
-               [ -e stamp-h.in ] && touch stamp-h.in ; \
-       );
        (cd $(PKG_BUILD_DIR)/$(strip $(3)); \
        if [ -x configure ]; then \
                $(TARGET_CONFIGURE_OPTS) \
@@ -309,7 +298,7 @@ define Build/Configure/Default
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                $(2) \
-               ./configure \
+               $(PKG_CONFIG_PATH)/configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \
@@ -350,8 +339,7 @@ define Build/Compile
 endef
 
 ifneq ($(DUMP),)
-  dumpinfo: FORCE
-       @$(DUMPINFO)
+  dumpinfo:
 else
   $(PACKAGE_DIR):
        mkdir -p $@