prepend $(STAGING_DIR)/host to the PATH only in target-package stampfile targets...
[openwrt/svn-archive/archive.git] / include / package.mk
index 13dece4c0e107980591fc691c82558bc7ff16842..80836326841a5a581835045b907ecc1bca5e3c43 100644 (file)
@@ -69,6 +69,7 @@ define Build/DefaultTargets
   $(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
   $(call Build/Autoclean)
 
+  $(STAMP_PREPARED) : export PATH=$$(TARGET_PATH_PKG)
   $(STAMP_PREPARED):
        @-rm -rf $(PKG_BUILD_DIR)
        @mkdir -p $(PKG_BUILD_DIR)
@@ -77,12 +78,14 @@ define Build/DefaultTargets
        $(foreach hook,$(Hooks/Prepare/Post),$(call $(hook))$(sep))
        touch $$@
 
-  $(STAMP_CONFIGURED): $(STAMP_PREPARED)
+  $(STAMP_CONFIGURED) : export PATH=$$(TARGET_PATH_PKG)
+  $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(HOST_STAMP_INSTALLED)
        $(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
        $(Build/Configure)
        $(foreach hook,$(Hooks/Configure/Post),$(call $(hook))$(sep))
        touch $$@
 
+  $(STAMP_BUILT) : export PATH=$$(TARGET_PATH_PKG)
   $(STAMP_BUILT): $(STAMP_CONFIGURED)
        $(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
        $(Build/Compile)
@@ -91,6 +94,7 @@ define Build/DefaultTargets
        $(foreach hook,$(Hooks/Install/Post),$(call $(hook))$(sep))
        touch $$@
 
+  $(STAMP_INSTALLED) : export PATH=$$(TARGET_PATH_PKG)
   $(STAMP_INSTALLED): $(STAMP_BUILT)
        $(SUBMAKE) -j1 clean-staging
        rm -rf $(TMP_DIR)/stage-$(PKG_NAME)