check for empty patch directories
[openwrt/svn-archive/archive.git] / include / package.mk
index 5a9ba861af1b9fca3cc559455a48ff58b82d2ba6..87e76be2b53248470485c0c317310ce490111038 100644 (file)
@@ -12,6 +12,7 @@ endif
 
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/unpack.mk
 
 define shvar
 V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
@@ -269,15 +270,10 @@ define BuildPackage
   endif
 endef
 
-ifneq ($(strip $(PKG_CAT)),)
-  ifeq ($(PKG_CAT),unzip)
-    UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
-  else
-    UNPACK=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
-  endif
+ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
-       $(UNPACK)
-       @if [ -d ./patches ]; then \
+       $(PKG_UNPACK)
+       @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
                $(PATCH) $(PKG_BUILD_DIR) ./patches; \
        fi
   endef