remove autoconf from prereq-build.mk, as it is part of the tools/ build
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index d6d2d73a63c39549936e19f5e2e4c2920f2fbd55..0b396c83dd6278529d2469faa299d2d7029c82a9 100644 (file)
@@ -37,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
        OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
+define Require/getopt
+       getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+       Please install GNU getopt \
+))
+
+define Require/fileutils
+       gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+       Please install GNU fileutils \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
@@ -79,10 +93,6 @@ $(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \
 ))
 
-$(eval $(call RequireCommand,bison, \
-       Please install GNU bison. \
-))
-
 $(eval $(call RequireCommand,flex, \
        Please install flex. \
 ))
@@ -123,10 +133,6 @@ $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))
 
-$(eval $(call RequireCommand,autoconf, \
-       Please install GNU autoconf. \
-))
-
 define Require/gnu-find
        $(FIND) $(TMP_DIR) -lname foo
 endef