build: generate a list of provided libraries for each ipkg file (includes provided...
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index e4275eb..228fcdc 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -20,11 +20,7 @@ $(eval $(call Require,non-root, \
 
 # Required for the toolchain
 define Require/working-make
-       echo 'all: test' > $(TMP_DIR)/check.mk
-       echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 == "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
@@ -41,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
        OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
+define Require/getopt
+       getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+       Please install GNU getopt \
+))
+
+define Require/fileutils
+       gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+       Please install GNU fileutils \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
@@ -52,7 +62,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -61,7 +72,7 @@ $(eval $(call Require,working-g++, \
 
 define Require/ncurses
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
-               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out -lncurses -
+               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses
 endef
 
 $(eval $(call Require,ncurses, \
@@ -71,25 +82,17 @@ $(eval $(call Require,ncurses, \
 
 define Require/zlib
        echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out -lz -
+               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - -lz
 endef
 
 $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
-$(eval $(call RequireCommand,gwak, \
+$(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \
 ))
 
-$(eval $(call RequireCommand,bison, \
-       Please install GNU bison. \
-))
-
-$(eval $(call RequireCommand,flex, \
-       Please install flex. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))
@@ -106,10 +109,22 @@ $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
 
+$(eval $(call RequireCommand,python, \
+       Please install python. \
+))
+
 $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
 
+define Require/git
+       git --version | awk '($$$$1 == "git") && ($$$$2 == "version") && ($$$$3 >= "1.6.5") { print "ok" }' | grep ok > /dev/null
+endef
+
+$(eval $(call Require,git, \
+       Please install git (git-core) v1.6.5 or later. \
+))
+
 define Require/gnutar
        $(TAR) --version 2>&1 | grep GNU > /dev/null
 endef
@@ -118,6 +133,22 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
-$(eval $(call RequireCommand,autoconf, \
-       Please install GNU autoconf. \
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
+
+define Require/gnu-find
+       $(FIND) --version 2>/dev/null
+endef
+
+$(eval $(call Require,gnu-find, \
+       Please install GNU find \
+))
+
+define Require/getopt-extended
+       getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+       Please install an extended getopt version that supports --long \
 ))