ar71xx: fix AR934X_WMAC_SIZE
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index 0b396c83dd6278529d2469faa299d2d7029c82a9..5b3a7734b61adb8605c16bba0ecac5e23ccadad6 100644 (file)
@@ -62,7 +62,7 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out
 endef
 
@@ -72,7 +72,7 @@ $(eval $(call Require,working-g++, \
 
 define Require/ncurses
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
-               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out -lncurses -
+               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses
 endef
 
 $(eval $(call Require,ncurses, \
@@ -82,7 +82,7 @@ $(eval $(call Require,ncurses, \
 
 define Require/zlib
        echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out -lz -
+               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - -lz
 endef
 
 $(eval $(call Require,zlib, \
@@ -121,6 +121,10 @@ $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
 
+$(eval $(call RequireCommand,git, \
+       Please install git (git-core). \
+))
+
 define Require/gnutar
        $(TAR) --version 2>&1 | grep GNU > /dev/null
 endef
@@ -134,7 +138,7 @@ $(eval $(call RequireCommand,svn, \
 ))
 
 define Require/gnu-find
-       $(FIND) $(TMP_DIR) -lname foo
+       $(FIND) --version 2>/dev/null
 endef
 
 $(eval $(call Require,gnu-find, \