add PKG_NAME to prereq-build.mk so that failed checks show a proper prefix instead...
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index e9f3a0173f89990aa6ab4aefe9edd105a27ebdd3..78a278ead8286d4fbdc9e306c94f400274b18aa6 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 
+PKG_NAME:=Build dependency
+
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
 endef
@@ -112,3 +114,9 @@ endef
 $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
+
+$(eval $(call RequireCommand,autoconf, \
+       Please install GNU autoconf. \
+))
+
+