add a flag "IGNORE_ERRORS", which can be used to ignore build errors in packages
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index 7355b9e31c1e3c8cad24fd54897159717c3d8555..b0114f0b9e0a9b4e3a75e040c2de546afcda1496 100644 (file)
@@ -20,11 +20,7 @@ $(eval $(call Require,non-root, \
 
 # Required for the toolchain
 define Require/working-make
-       echo 'all: test' > $(TMP_DIR)/check.mk
-       echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
@@ -52,7 +48,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -118,14 +115,18 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
+
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
-define Require/find
-       find . -maxdepth 1 -exec ls {} + > /dev/null 2>&1
+define Require/gnu-find
+       $(FIND) $(TMP_DIR) -lname foo
 endef
 
-$(eval $(call Require,find, \
-       Please install GNU find 4.2.12 or better. \
+$(eval $(call Require,gnu-find, \
+       Please install GNU find \
 ))