[kernel] x86: Sync kernel config
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index 9b77a1baf70b32828aaeb6f0ace064b08fc031fc..b0114f0b9e0a9b4e3a75e040c2de546afcda1496 100644 (file)
@@ -20,11 +20,7 @@ $(eval $(call Require,non-root, \
 
 # Required for the toolchain
 define Require/working-make
-       echo 'all: test' > $(TMP_DIR)/check.mk
-       echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
@@ -119,14 +115,6 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
-define Require/git
-       which git-clone
-endef
-
-$(eval $(call Require,git, \
-       Please install git. \
-))
-
 $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))
@@ -135,3 +123,10 @@ $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
+define Require/gnu-find
+       $(FIND) $(TMP_DIR) -lname foo
+endef
+
+$(eval $(call Require,gnu-find, \
+       Please install GNU find \
+))