quilt is now a preriquisite
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index e9f3a0173f89990aa6ab4aefe9edd105a27ebdd3..bd1061bb435d27b66cfeab073c169ec313c8a4f7 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 
+PKG_NAME:=Build dependency
+
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
 endef
@@ -76,6 +78,9 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+$(eval $(call RequireCommand,gawk, \
+       Please install GNU awk. \
+))
 
 $(eval $(call RequireCommand,bison, \
        Please install GNU bison. \
@@ -112,3 +117,11 @@ endef
 $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
+
+$(eval $(call RequireCommand,autoconf, \
+       Please install GNU autoconf. \
+))
+
+$(eval $(call RequireCommand,quilt, \
+       Please install quilt. \
+))