Allow installing gcj/gnu classpath,for those interested
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index bd1061bb435d27b66cfeab073c169ec313c8a4f7..c31020c3211d528acca14d8d4a1a233652dfb1d6 100644 (file)
@@ -52,7 +52,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -122,6 +123,3 @@ $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
-$(eval $(call RequireCommand,quilt, \
-       Please install quilt. \
-))