add TARPIT support to netfilter/iptables
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index d3aec643999c81501b5adc8f73d7189097dfc6ac..c31020c3211d528acca14d8d4a1a233652dfb1d6 100644 (file)
@@ -52,7 +52,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -121,3 +122,4 @@ $(eval $(call Require,gnutar, \
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
+