Allow installing gcj/gnu classpath,for those interested
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index e4275ebbebfc878dc12f135450a5d3a1aeb5a55a..c31020c3211d528acca14d8d4a1a233652dfb1d6 100644 (file)
@@ -52,7 +52,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -78,7 +79,7 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
-$(eval $(call RequireCommand,gwak, \
+$(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \
 ))
 
@@ -121,3 +122,4 @@ $(eval $(call Require,gnutar, \
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
+