fix CONFIG_FILENAME in uci_commit()
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index 486f573f83981d27a7a081506125ff34aa906673..c73b12438fff3916441aa22a76ba4216f6aa2ebd 100644 (file)
@@ -6,7 +6,6 @@
 #
 
 include $(TOPDIR)/rules.mk
-TMP_DIR:=$(TOPDIR)/tmp
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 
@@ -30,6 +29,16 @@ $(eval $(call Require,working-make, \
        Please install GNU make v3.81 or later. (This version has bugs) \
 ))
 
+define Require/case-sensitive-fs
+       rm -f $(TMP_DIR)/test.*
+       touch $(TMP_DIR)/test.fs
+       [ \! -f $(TMP_DIR)/test.FS ]
+endef
+
+$(eval $(call Require,case-sensitive-fs, \
+       OpenWrt can only be built on a case-sensitive filesystem \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
@@ -76,10 +85,6 @@ $(eval $(call RequireCommand,flex, \
        Please install flex. \
 ))
 
-$(eval $(call RequireCommand,python, \
-       Please install python. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))
@@ -107,3 +112,9 @@ endef
 $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
+
+$(eval $(call RequireCommand,autoconf, \
+       Please install GNU autoconf. \
+))
+
+